天天瞎忙活,QQ:705719110,欢迎来撩!

CentOS6升级Python2.7

Linux系统 随风 130℃ 0评论

买了一台梅乖的服务器,配置一个服务的时候需要使用pip,直接安装的时候发现报错了,查看了一下最好把Python升级到2.7,于是乎升级了。先安装依赖包

我这个服务器还没有编译器,安装之

下载Python2.7的源码包编译安装

建立软连接,原来的是指向Python2.6.6的,使系统默认的 Python指向 Python2.7

修复yum,安装2.7之后,尤其是软连接成功后,yum就会废,因为yum不兼容2.7,这里就把yum关联到2.6.6上

现在再试试yum指令,应该可以用了!

最主要的是pip,之前Python2.6.6安装pip就报错了,这里来装一下,先安装setup_tool:

之后安装pip:

如果这样安装中间报错:

就安装:

这样就OK了,愉快的去配置某些服务了~~

转载请注明:怼码人生 » CentOS6升级Python2.7

喜欢 (0)
发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址