天天瞎忙活,QQ:705719110,欢迎来撩!

配置本地PHP开发环境

PHP开发 随风 365℃ 0评论

在我们学习任何一门语言之前都要配置好这门语言相应的本地开发环境,PHP也不例外。PHP的开发环境需要PHP解释器、web服务器、数据库组合而成的,由于是本地的开发环境,所以并不推荐使用他们各自的安装包去分开安装,这样会在配置的时候出现很多问题,更不要说对于不是很了解系统的新手了,我们推荐的是集成的开发环境。下面我就介绍一下PHP本地开发环境的配置。

在windows下常用的是phpStudy、wamp、appserv,他们都集成了上面提到的三种必须服务:
其中phpstudy是国内的一款集成环境,集成的是 php(版本较多,切换方便),Apache,nginx,MySql,安装是傻瓜式的一键安装,使用操作简单。
wamp集成的是 php(版本较少),Apache,MySql,安装也是傻瓜式的一键安装,使用操作也很简单,就是经常出问题。
appserv集成的是 php(版本较少),Apache,MySql,安装也是傻瓜式的一键安装,使用操作简单,然而支持的系统不是很好。

不过以上都是 FREE 免费的,随便选择一款都可以满足我们的需求了。

在Mac OS下常用的是MAMP(也有win版),这个软件分为免费版和专业收费版,但是我们做开发你懂得,不过没关系,网上各种注册码满天飞,这里给出一个,多次亲测可用。

MAMP包含的php版本也不少,切换方便,服务器是Apache,数据库是MySql,使用起来很方便。

以上的集成环境都包含的有web版数据库管理软件 phpmyadmin ,MAMP还有其他几款数据库管理软件,挺方便使用的。

下面再说一下开发IDE的选择,我们用过的是 phpDesigner 、 phpstorm 、NetBeans,当然还有炒鸡好用的前端利器sublime text了,不过这些软件大部分都是收费的!收费的!!收费的!!!但是这都不是事,难不倒大天朝的程序猿群众,这里奉献几个注册码(强力推荐的phpstorm、sublime text)

phpstorm

sublime text(按版本区分)
Sublime Text 2.x 版本

Sublime Text 3.x(Bulid 309X 之前版本)
适用于3065 / 3083 等低于 309x 的版本

或者

或者

Sublime Text 3.X(Bulid 309x之后版本)
适用于 3103 等高于 309x 的版本

或者

或者

或者

或者

或者

或者

或者

或者

或者

或者

转载请注明:怼码人生 » 配置本地PHP开发环境

喜欢 (0)
发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址