天天瞎忙活,QQ:705719110,欢迎来撩!

这两天遇到的问题

工具软件 随风 637℃ 0评论

之前在配置开发环境,遇到了几个小问题,这里记录一下

配置cocoapods时候报错

新配置的环境,在pod setup的时候耗时间还报错,处理了一下

当然还有朋友嫌慢,有个朋友自己在阿里云做了个镜像,每小时更新一次,可以用之替换github的源

使用方法

不过最好的方法还是在Podfile文件开头定好源地址

Flutter – Migrate to AndroidX

之前学flutter创建的项目,最近打开之后发现不能运行了,报了个错

大概意思是说,安卓依赖在编译时和运行时出现了不同的版本,因为有了AndroidX的出现。还是很坑的啊,官方提供了两个解决方式,手动升级(不推荐)和自动升级,只用了自动升级,方法可以查看这个地址 https://goo.gl/CP92wY

使用3.2以上版本的Android Studio打开flutter项目中的android文件夹(其实就是个安卓项目),会自动检测,检测完成后会提示你升级,升级完再尝试编译你的flutter项目,有人成功了,而我失败了,所以我选择了更暴力的方法,重新创建了个项目,把我的文件都复制进去了。。。

Flutter 环境问题

安装好flutter以后一定要看官方的提示,在国内要配置两个环境变量,不然装依赖的时候慢到爆,mac下编辑~/.bash_profile 文件填写下面两句,然后source ~/.bash_profile就行了

转载请注明:怼码人生 » 这两天遇到的问题

喜欢 (1)
头像
发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址